CRAN Package Check Results for Package stevedore

Last updated on 2020-05-29 17:49:18 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.9.3 9.15 130.98 140.13 OK
r-devel-linux-x86_64-debian-gcc 0.9.3 6.53 98.20 104.73 OK
r-devel-linux-x86_64-fedora-clang 0.9.3 182.75 OK
r-devel-linux-x86_64-fedora-gcc 0.9.3 174.98 OK
r-devel-windows-ix86+x86_64 0.9.3 20.00 177.00 197.00 ERROR
r-patched-linux-x86_64 0.9.3 8.41 129.88 138.29 OK
r-patched-solaris-x86 0.9.3 194.30 NOTE
r-release-linux-x86_64 0.9.3 8.99 131.98 140.97 OK
r-release-osx-x86_64 0.9.3 OK
r-release-windows-ix86+x86_64 0.9.3 12.00 249.00 261.00 ERROR
r-oldrel-osx-x86_64 0.9.3 OK
r-oldrel-windows-ix86+x86_64 0.9.3 20.00 137.00 157.00 ERROR

Check Details

Version: 0.9.3
Check: tests
Result: ERROR
     Running 'testthat.R' [53s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(stevedore)
     >
     > test_check("stevedore")
     -- 1. Failure: python_locate_version (@test-httppipe-unix.R#97) ---------------
     `python_locate_version("nosuchmodule")` threw an error with unexpected message.
     Expected match: "Did not find required python module 'nosuchmodule'"
     Actual message: "lexical error: invalid char in json text.\n NA\n (right here) ------^\n"
     Backtrace:
     1. testthat::expect_error(...)
     6. stevedore:::python_locate_version("nosuchmodule")
     7. reticulate::py_discover_config(module)
     8. reticulate:::python_conda_versions()
     11. reticulate::conda_list(conda = conda)
     12. jsonlite::fromJSON(conda_envs)
     13. jsonlite:::parse_and_simplify(...)
     14. jsonlite:::parseJSON(txt, bigint_as_char)
     15. jsonlite:::parse_string(txt, bigint_as_char)
    
     -- 2. Failure: python_locate_version (@test-httppipe-unix.R#100) --------------
     `python_locate_version("nosuchmodule")` threw an error with unexpected message.
     Expected match: "Did not find required python module 'nosuchmodule'"
     Actual message: "lexical error: invalid char in json text.\n NA\n (right here) ------^\n"
     Backtrace:
     1. testthat::expect_error(...)
     6. stevedore:::python_locate_version("nosuchmodule")
     7. reticulate::py_discover_config(module)
     8. reticulate:::python_conda_versions()
     11. reticulate::conda_list(conda = conda)
     12. jsonlite::fromJSON(conda_envs)
     13. jsonlite:::parse_and_simplify(...)
     14. jsonlite:::parseJSON(txt, bigint_as_char)
     15. jsonlite:::parse_string(txt, bigint_as_char)
    
     == testthat results ===========================================================
     [ OK: 3275 | SKIPPED: 159 | WARNINGS: 3 | FAILED: 2 ]
     1. Failure: python_locate_version (@test-httppipe-unix.R#97)
     2. Failure: python_locate_version (@test-httppipe-unix.R#100)
    
     Error: testthat unit tests failed
     In addition: Warning message:
     In extract_lang(f = comp_lang, y = quote(if (.isMethodsDispatchOn() && :
     devtools is incompatible with the current version of R. `load_all()` may function incorrectly.
     Execution halted
Flavor: r-devel-windows-ix86+x86_64

Version: 0.9.3
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘redux’
Flavor: r-patched-solaris-x86

Version: 0.9.3
Check: tests
Result: ERROR
     Running 'testthat.R' [84s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(stevedore)
     >
     > test_check("stevedore")
     -- 1. Failure: python_locate_version (@test-httppipe-unix.R#97) ---------------
     `python_locate_version("nosuchmodule")` threw an error with unexpected message.
     Expected match: "Did not find required python module 'nosuchmodule'"
     Actual message: "lexical error: invalid char in json text.\n NA\n (right here) ------^\n"
     Backtrace:
     1. testthat::expect_error(...)
     6. stevedore:::python_locate_version("nosuchmodule")
     7. reticulate::py_discover_config(module)
     8. reticulate:::python_conda_versions()
     11. reticulate::conda_list(conda = conda)
     12. jsonlite::fromJSON(conda_envs)
     13. jsonlite:::parse_and_simplify(...)
     14. jsonlite:::parseJSON(txt, bigint_as_char)
     15. jsonlite:::parse_string(txt, bigint_as_char)
    
     -- 2. Failure: python_locate_version (@test-httppipe-unix.R#100) --------------
     `python_locate_version("nosuchmodule")` threw an error with unexpected message.
     Expected match: "Did not find required python module 'nosuchmodule'"
     Actual message: "lexical error: invalid char in json text.\n NA\n (right here) ------^\n"
     Backtrace:
     1. testthat::expect_error(...)
     6. stevedore:::python_locate_version("nosuchmodule")
     7. reticulate::py_discover_config(module)
     8. reticulate:::python_conda_versions()
     11. reticulate::conda_list(conda = conda)
     12. jsonlite::fromJSON(conda_envs)
     13. jsonlite:::parse_and_simplify(...)
     14. jsonlite:::parseJSON(txt, bigint_as_char)
     15. jsonlite:::parse_string(txt, bigint_as_char)
    
     == testthat results ===========================================================
     [ OK: 3275 | SKIPPED: 159 | WARNINGS: 3 | FAILED: 2 ]
     1. Failure: python_locate_version (@test-httppipe-unix.R#97)
     2. Failure: python_locate_version (@test-httppipe-unix.R#100)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-release-windows-ix86+x86_64

Version: 0.9.3
Check: tests
Result: ERROR
     Running 'testthat.R' [62s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(stevedore)
     >
     > test_check("stevedore")
     -- 1. Failure: python_locate_version (@test-httppipe-unix.R#97) ---------------
     `python_locate_version("nosuchmodule")` threw an error with unexpected message.
     Expected match: "Did not find required python module 'nosuchmodule'"
     Actual message: "lexical error: invalid char in json text.\n NA\n (right here) ------^\n"
     Backtrace:
     1. testthat::expect_error(...)
     6. stevedore:::python_locate_version("nosuchmodule")
     7. reticulate::py_discover_config(module)
     8. reticulate:::python_conda_versions()
     10. reticulate::conda_list(conda = conda)
     11. jsonlite::fromJSON(conda_envs)
     12. jsonlite:::parse_and_simplify(...)
     13. jsonlite:::parseJSON(txt, bigint_as_char)
     14. jsonlite:::parse_string(txt, bigint_as_char)
    
     -- 2. Failure: python_locate_version (@test-httppipe-unix.R#100) --------------
     `python_locate_version("nosuchmodule")` threw an error with unexpected message.
     Expected match: "Did not find required python module 'nosuchmodule'"
     Actual message: "lexical error: invalid char in json text.\n NA\n (right here) ------^\n"
     Backtrace:
     1. testthat::expect_error(...)
     6. stevedore:::python_locate_version("nosuchmodule")
     7. reticulate::py_discover_config(module)
     8. reticulate:::python_conda_versions()
     10. reticulate::conda_list(conda = conda)
     11. jsonlite::fromJSON(conda_envs)
     12. jsonlite:::parse_and_simplify(...)
     13. jsonlite:::parseJSON(txt, bigint_as_char)
     14. jsonlite:::parse_string(txt, bigint_as_char)
    
     == testthat results ===========================================================
     [ OK: 3275 | SKIPPED: 159 | WARNINGS: 3 | FAILED: 2 ]
     1. Failure: python_locate_version (@test-httppipe-unix.R#97)
     2. Failure: python_locate_version (@test-httppipe-unix.R#100)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64