CRAN Package Check Results for Package microsimulation

Last updated on 2021-06-22 09:51:42 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.3.4 97.36 70.64 168.00 OK
r-devel-linux-x86_64-debian-gcc 1.3.4 63.37 54.64 118.01 OK
r-devel-linux-x86_64-fedora-clang 1.3.4 229.14 NOTE
r-devel-linux-x86_64-fedora-gcc 1.3.4 200.59 OK
r-devel-windows-x86_64 1.3.4 109.00 74.00 183.00 NOTE
r-devel-windows-x86_64-gcc10-UCRT 1.3.4 OK
r-patched-linux-x86_64 1.3.4 74.40 68.77 143.17 OK
r-patched-solaris-x86 1.3.4 214.90 NOTE
r-release-linux-x86_64 1.3.4 75.04 69.17 144.21 OK
r-release-macos-arm64 1.3.4 WARN
r-release-macos-x86_64 1.3.4 WARN
r-release-windows-ix86+x86_64 1.3.4 209.00 123.00 332.00 NOTE
r-oldrel-macos-x86_64 1.3.4 WARN

Check Details

Version: 1.3.4
Check: installed package size
Result: NOTE
     installed size is 18.7Mb
     sub-directories of 1Mb or more:
     doc 6.0Mb
     lib 8.3Mb
     libs 3.6Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-x86_64, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64, r-oldrel-macos-x86_64

Version: 1.3.4
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     tprocess.cc:70:9: warning: 'swapcontext' is deprecated: first deprecated in macOS 10.6 - No longer supported [-Wdeprecated-declarations]
     tprocess.cc:89:9: warning: 'swapcontext' is deprecated: first deprecated in macOS 10.6 - No longer supported [-Wdeprecated-declarations]
     tprocess.cc:148:9: warning: 'getcontext' is deprecated: first deprecated in macOS 10.6 - No longer supported [-Wdeprecated-declarations]
     tprocess.cc:157:5: warning: 'makecontext' is deprecated: first deprecated in macOS 10.6 - No longer supported [-Wdeprecated-declarations]
     tprocess.cc:159:9: warning: 'swapcontext' is deprecated: first deprecated in macOS 10.6 - No longer supported [-Wdeprecated-declarations]
Flavor: r-release-macos-arm64

Version: 1.3.4
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     tprocess.cc:70:9: warning: 'swapcontext' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
     tprocess.cc:89:9: warning: 'swapcontext' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
     tprocess.cc:148:9: warning: 'getcontext' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
     tprocess.cc:157:5: warning: 'makecontext' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
     tprocess.cc:159:9: warning: 'swapcontext' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
Flavors: r-release-macos-x86_64, r-oldrel-macos-x86_64